Incident Report – July 3, 2026 (General) Major Outage Resolved

GeneralStarted UTC • resolved UTC • Duration

  • Investigating

    Incident Report – July 3, 2026

    On July 3, 2026, our network was targeted by a large-scale distributed denial-of-service (DDoS) attack that affected multiple MVPS locations simultaneously.

    The attack generated an exceptionally large volume of malicious traffic, resulting in temporary service disruptions across parts of our infrastructure. While our DDoS protection systems automatically mitigated a significant portion of the attack, additional measures were required before normal service could be fully restored.

    Throughout the incident, our engineering team worked continuously alongside our upstream network providers to analyze the attack, deploy additional filtering, optimize traffic routing, and implement further mitigation measures. Once these actions were in place, services gradually returned to normal operation.

    Following the incident, we have further strengthened our infrastructure by expanding our mitigation capabilities, improving traffic filtering, and implementing additional protective measures designed to reduce the impact of similar attacks in the future.

    We would also like to clarify that our public status page was launched after this incident had already been resolved. For this reason, it currently reports 100% uptime starting from the date it became operational and does not include historical incidents that occurred before its deployment.

    We sincerely apologize for the disruption and any inconvenience this incident may have caused. We appreciate the patience, understanding, and continued trust of our customers while we worked to restore full service.

    Thank you for choosing MVPS.

  • Resolved Latest

    Incident resolved on the 3rd of July.