Greece - Cogent outage (Greece VPS) Degraded Performance Resolved

Greece VPSStarted UTC • resolved UTC • Duration

  • Investigating

    There was a Cogent network outage in Greece that affected some international connectivity for approximately two hours. The issue has now been resolved.

  • Resolved Latest

    The issue has been resolved.